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Introduction 
NEC Communications Analyst is an easy to use, graphically oriented software package that 
allows you to monitor and analyze phone calls, understand phone usage and cut costs.  NEC 
Communications Analyst tracks both incoming and outgoing calls accurately as well as the date 
and time of each call. If you need to track the incoming phone call with name and/or telephone 
numbers, NEC Communications Analyst requires Caller ID services from the local phone 
company. 

NEC Communications Analyst increases productivity, facilitates billing and helps detect toll 
fraud and phone abuse. It also has powerful tabular (text) and graphical report generating 
capabilities. Reports can be used to analyze your telephone as a critical business 
communication tool thereby improving its effectiveness and reducing your telephone related 
costs. 

NEC Communications Analyst keeps track of: 

• The date and time when calls were made or received 

• The duration of each call 

• The extension from which calls were made or received 

• The CID/ANI and DNIS of the caller 

• The trunk or line numbers which handled the call 

• The account codes and authorization codes used  

For example, a report can be generated showing calling patterns by volume or duration on a 
color-coded map of the United States. 

 

This can help the Customer Support, Sales or the Telemarketing business to become more 
focused, productive and cost-effective. 
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Included Reports 
• Date and time summaries 
• Most frequently called numbers 
• Department summaries 
• Extension and line summaries 
• Longest and most expensive calls 

 

Introduction to Multi Site Reporting 
NEC Communications Analyst allows you to capture call data from switches (phone systems) 
located across multiple sites. The Call Data Manager known as Multi Site Reporting Call Data 
Manager (MSRCDM) located in the NEC Communications Analyst captures call information 
from multiple switches (phone systems) located across different remote sites. The MSRCDM is 
centrally located in the NEC Communications Analyst for each site. You can connect a 
maximum of 99 MSRCDM at a time. It collects the call records from different switches (phone 
systems) and pulls them into the Data Manager, which in turn stores them into the NEC 
Communications Analyst database. You can configure the MSRCDM based on the 
requirements. For details, refer to the Installation Guide. 

NEC Communications Analyst uses the Multisite Advanced Parser (MSAdvPars) process to 
discard any duplicate call records received from the source. MSAdvPars also updates the NEC 
Communications Analyst database with new extensions, lines, phone numbers and caller ID 
names dynamically. 

Both of these processes (MSRCDM and MSAdvPars) along with the Multi Site Data Manager 
(MSDM) are started and monitored by Multi Site Process Manager (MSPM), a Windows 32 
service. This service starts automatically, whenever you start the NEC Communications 
Analyst application. If any of these processes shuts down, MSPM restarts them. If you shut 
down the MSPM service, all the above processes shut down automatically. 

 

Using NEC Communications Analyst Databases 
NEC Communications Analyst uses Microsoft SQL databases to store contact information, 
phone numbers and call records. It is recommended to make regular backups of your database 
on a periodic basis by archiving your call records.  Whenever required, you can also restore 
these archived files. 

 

Sending Call Information to Computer 
Upon completion of an inbound or outbound call, your phone system sends Station Message 
Detail Records (SMDR) data about the call (For example, extension called, number dialed, date 
and time). Once the phone system sends the SMDR data, it is usually erased from the phone 
system based on the assumption that an external device has recorded the data. The Call Data 
Manager (CDM) records all SMDR data sent from the phone system to your PC via a serial 
cable. The CDM is included as a part of the NEC Communications Analyst installation. 

NOTE: Call Data Sources will be enabled depending on the phone system supportability. 

Most phone systems have a serial SMDR port much like the COM1, COM2, COM3 and COM4 
ports on your PC. The SMDR port can be enabled or disabled by programming the phone 
system. For specific SMDR related questions and phone system programming, refer to your 
phone system manual. 
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Getting Started 
Only if security is enabled in the User Management application you will be prompted to enter 
your user name and password to log on to NEC Communications Analyst. If you do not have 
this information, contact your System Administrator. 

Some of the functionalities in NEC Communications Analyst are enabled only if you login as an 
Administrator. They are as follows: 

• Archiving or restoring database 
• Setting up rate plan 
• Automating report and archiving process 
• Importing extensions and setting up extension file format 
• Importing call records 
• Assigning phone number  
• Assigning name and number 
• Replacing menu options 
• Automating multi-site 
• Calculating call costing 
• Creating, assigning or editing extensions, accounts and lines respectively 
• Creating departments and/or groups 
• Deleting call records 
• Viewing call history of a contact 
• Creating and/or modifying client matter 
• Customizing client matter  

 

Some of the functionalities in NEC Communications Analyst are available both for the 
Administrator and Business Users. They are as follows: 

• Viewing reports 
• Viewing all calls, inbound calls and outbound calls 
• Viewing contacts and importing contacts 
• Changing password of individual accounts 

 

To log on to NEC Communications Analyst  

1. Select Start>Programs>NEC>Communications Analyst>Communications Analyst 

The Login to NEC Communications Analyst window appears, if you have enabled the 
security. 

 

2. Enter a User Name and Password. 

3. Click OK. 
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The main NEC Communications Analyst window appears. 

 You are now ready to analyze your call records. 

 

Changing Your Password 
NEC Communications Analyst allows you to change your password as and when required. 

To change the password 

1. From the Edit menu, select Change Password. 

The Change Password window appears. 

 

2. Enter the new password  

3. Click Save. 

Your new password becomes effective only from the next log in. 
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Understanding Menu Icons 
The following list describes the icons displayed at the top of the NEC Communications Analyst 
Main Window: 

 

 

• All Calls: Displays the All Call Records window, which shows all call records sorted by 
date and time. This is the same as the View>All Calls menu item. 

• Inbound: Displays the Inbound Call Records window, which shows all incoming call 
records sorted by date and time. This is the same as the View>Inbound Calls menu 
item. 

• Outbound: Displays the Outbound Call Records window, which shows outgoing call 
records sorted by date and time. This is the same as the View>Outbound Calls menu 
item. 

• Internal Calls: Displays the Internal Call Records window, which shows station-to-
station call records sorted by date and time. This is same as the View>Internal Calls 
menu item. 

• Reports: Displays the Reports window, which allows you to generate reports based on 
the type of report, the report dates and many other criteria. 

• Contacts: Displays the Contact window, which allows you to assign phone numbers to 
a contact, report the calls made to/from a contact or generate a billing report for a 
specific contact. This is the same as the Edit>Contacts menu item. 

• Delete: Allows you to delete a set of call records. Your business may generate a large 
volume of call records and the delete function allows you to trim your call records 
database to a manageable size. This is the same as the Tools>Delete Call Records 
menu item. 

• Help: This button displays the NEC Communications Analyst help. 
• Exit: This button closes NEC Communications Analyst. 

• Link launches other applications that are installed using NEC common installer. These 
applications appear under the LINK menu item after the installation.  
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Configuring NEC Communications Analyst  
NEC Communications Analyst uses call information from your phone system to create a list of 
extensions, lines, and account codes that were used in inbound and outbound calls. Instead of 
specifying each extension, account code, and/or line every time you generate a report, you can 
organize the extension, line, and account code data into groups and departments. During 
report generation, you need to specify only the group or department in the selection criteria. 

You can view or select the extensions, accounts, lines, groups and departments that belong to 
the corresponding site. You can also view or select extensions, accounts or lines that are not 
assigned to any other site. 

NEC Communications Analyst allows you to: 
� Associate Phone Numbers and Names 
� Create Groups and Departments 
� Manage Extensions 
� Manage Lines 
� Manage Account Codes 
� Specify Plan Rates 
� Open other applications that are supported and installed along with NEC Installer using 

LINK 

 

Associating Phone Numbers and Names 
NEC Communications Analyst allows you to assign a name to a phone number and vice versa. 
Thus, you can quickly assign Line Names to sets of phone numbers. 

 

To assign a name to a phone number in your database 

1. From the View menu, select Inbound Calls (to view details of all the incoming calls) or 
Outbound Calls (to view details of all the outbound calls) or All Calls (to view both 
incoming and outgoing calls). 

Or 

On the toolbar, click All Calls or Inbound or Outbound. 

The All Call Records or Inbound Call Records or Outbound Call Records window 
appears based on the selection. 

2. Select a phone number from the Call Record window. This is an optional step. 

3. From the Edit menu, select Assign Name to a Number. 

The Assign Name to A Number window appears. 

4. Type a number that you want to assign and click OK. 

5. Type a name that you wish to place in all the name fields for this phone number. 

6. Click OK. 

 

To assign a phone number to a name in your database 

1. From the View menu, select Inbound Calls (to view details of all the incoming calls) or 
Outbound Calls (to view details of all the outbound calls) or All Calls (to view both 
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incoming and outgoing calls). 

Or 

2. On the toolbar, click All Calls or Inbound or Outbound. 

The All Call Records or Inbound Call Records or Outbound Call Records window 
appears based on the selection.  

3. Select a phone number from the Phone Number column in the Call Record window. 
This is an optional step.  

4. From the Edit menu, select Assign Number To A Name.  

The Assign Number To A Name window appears.  

5. Type a name that you want to assign and click OK.  

6. Type a number that you wish to place in all the phone number fields for this name.  

7. Click OK.  

 

Managing Groups and Departments 
Groups allow you to specify a set of extensions, lines or account codes that you can use to 
generate reports. A department contains a set of groups. Depending on the number of 
extensions that your company has, a department may be your entire company or you may 
define several departments containing numerous groups. 

 

To specify groups and departments 

1. From the Edit menu, select Configure Site. 

The Selector window appears. 

 

2. Select a site from the left pane. 

3. Click New Department. 
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The New Department window appears. 

4. In the Department Name box, type the department name. You cannot use an 
apostrophe in the name. 

5. In the Dept Identifier box, type the unique key for the department. 

6. Click OK. 

The new department appears on the left pane of the Selector window. You can now add a 
group within the new department. 

 

To specify a new group 

1. Select a department from the left pane. 

2. Click New Group. 

The New Group window appears. 

3. In the Group Name box, type the group name. You cannot use an apostrophe in the 
name. 

4. In the Group Identifier box, type the unique key for the group. 

5. Click OK. 

 

To use a particular group or department for report generation 

1. Open criteria module from Reports window 

2. In criteria window, click on the button labeled “Select.” 

3. Select the group or the department that you want to use and right-click. 

4. Click Select. 

All the reports are generated using the selected group or department. If you select a 
department, all the groups in that department are selected automatically. 

To delete a group or department 

1. Select the group or the department that you want to delete and right-click. 

2. Select Delete Item. 

If you delete a department all the groups in that department is automatically deleted. The 
extensions will not be deleted from the Master Extension List. 

 

Managing Extensions 
 

To add a new extension 

1. From the Edit menu, select Configure Site. 

The Selector window appears. 
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2. Click the Extensions tab. 

The Master Extension List appears in the right pane. 

 

To create a new extension 

1. Click New Extn. 

The New Extension window appears. 

2. In the Extension Name box, type the extension name. 

3. In the Extension Number box, type the extension number. 

4. In the Site box, type the site code. 

5. Click OK. 

The new extension is added to the Master Extension List. 

 

To delete an extension from the Master Extension List 

1. Select the extension that you want to delete. 

2. Press the [DELETE] key on the keyboard. 

 

To assign an extension to a group 

1. Select a group from the left pane of the Selector window. 

If no groups are defined in the left pane of the Selector window, then you must first 
define a department and a group. You can assign extensions only to groups, not to 
departments. 

2. Select extensions from the right pane of the Selector window. 

a. You can select multiple extensions by holding down the Ctrl key while 
selecting. 
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3. Click Assign Extension. 

The extension(s) is/are listed under the group. 

NOTE: Extensions can be assigned to a single group at a time. Records/Page, this option 
loads the number of extensions per page and by default only 15 extensions will be seen by a 
user. If user wishes to load more extensions, please select values from the drop down list. 

 

To edit the extension name or number 

1. Select the extension name or number fields in the Master Extension List. 

2. Click Edit Extn. 

The Edit Extension window appears. 

3. Make the necessary changes and click OK. 

 

Setting Up Extension File Format  
NEC Communications Analyst has the ability to import extension information from an existing 
file. You should set the format of the file that contains the data for all extensions. 

To set the file format 

1. From the Tools menu, point to Extensions. 

2. Select Set Extension File Format. 

The Set Extension File Format window appears. 

 

3.  From the Delimiter drop-down, select the delimiter that is used after each column. 

None: Indicates that no delimiter is used after each column. If the Start position against 
each column is set as 0 (zero), then that column is not considered while importing. The 
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columns and their values are positioned according to the Start and End position. 

Comma (,) or Slash (/): Indicate that each column should be separated by a comma or 
slash. The columns are displayed according to the Order that you set against each 
field. If the Order against each column is set as 0 (zero), then that column is not 
considered while importing. 

4. The Site Code is displayed by default. You can change the site code, if required. 

5. Specify the required Start and End value against each column. 

6. Click Save.  

 

Importing Extensions 
NEC Communications Analyst allows you to import extensions from a Text file. You can also 
collect a set of extensions from one or many locations for later analysis. 

To import call records 

1. From the Tools menu, point to Extensions. 

2. Select Import Extensions. 

The Import Extensions window appears. 

 

3. Click Browse to select the file from where you want to import extensions. 

4. Click OK. 

On successful completion, the Finished Importing Extensions window appears. 

5. Click OK. 

To view errors (if any), do the following: 

1. Click the Windows Start button; point to Programs  

2. Click Start>Program Files>NEC>Communications Analyst. 

3. Point to Activity Logs and select Data Import. 

The errors.txt file opens.  
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Managing Lines 
Lines are the phone lines (trunks) coming from your local CO to your phone system. When you 
make or receive a call, your phone system provides the relevant information to the NEC 
Communications Analyst about the phone line. NEC Communications Analyst allows you to 
edit line names and their associated phone numbers to help generate specific reports. For 
example, if your fax machine has a separate line, then you can exclude your fax line from the 
reports or generate a separate report for just the fax line. You can also make separate groups 
for your lines if you have different lines for different departments or for different long distance 
carriers. 

 

To add a new line 

1. From the Edit menu, select Line Group Selector. 

The Line Group Selector window appears. 

 

2. Click New Line. 

The New Line window appears. 

3. In the Line Name box, type the name of the line. 

4. In the Phone Number box, type the phone number. 

5. In the Line/Trunk Number box, type the line or the trunk number. 

6. In the CTX Code Length box, type the CTX Code Length. It is the number of digits 
dialed to access a Centrex line for each line or trunk. Each line or the trunk has a fixed 
number of access digits. If there is no access digits used on a given line or trunk, then 
you can type 0 (zero). 

7. In the Site box, type site code. 

 

To delete a line from the Master Line/Trunk List 

1. Select the line that you want to delete. 
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2. Press the [DELETE] key on the keyboard. 

To assign a line to a group 

1. Select a group from the left pane of the Line Group Selector window. 

If no groups are defined in the left pane of the Line Group Selector window, then you 
must first define a group. You can assign lines only to groups, not to departments. 

2. Select a line from the right pane of the Line Group Selector window. 

a. You can select multiple lines by holding down the Ctrl key while selecting. 

3. Click Assign Line. 

The line(s) is/are listed under the group. 

To edit the line name or number 

1. Select the line name or line number field in the Master Lines/Trunks List. 

2. Click Edit Line. 

The Edit Line window appears. 

3. Make the necessary changes and click OK. 

 

NOTE: Records/Page, this option loads the number of Lines/Trunks per page and by default 
only Lines/Trunks will be seen by a user. If user wishes to load more Lines/Trunks, please 
select values from the drop down list. 

 

 

Managing Account Codes 
Account codes are defined in your phone system. NEC Communications Analyst receives the 
account code information from the phone system. You can assign these account codes to the 
proper groups and departments. This helps you in proper analysis. 

To add a new account code 

1. From the Edit menu, select Configure Site. 

The Selector window appears. 
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2. Click the Accounts tab. 

The Master Account Code List window appears. 

 

To create a new account 

1. Click New Account. 

The New Account window appears. 

2. In the Account Name box, type the name of the account. 

3. In the Account Number box, type the unique account number. 

4. In the Hourly Rate (Time Billing) box, type the rate per hour for a phone call. The 
account is charged based on the rate mentioned. 

5. In the Site box, type the site number. 

 

To delete an account code from the Master Account Code List 

1. Select the account that you want to delete. 

2. Press the [DELETE] key on the keyboard. 

 

To assign an account code to a group 

1. Select a group from the left pane of the Selector window. 

If no groups are defined in the left pane of the Selector window, then you must first define a 
department and a group. You can assign extensions only to groups, not to departments. 

2. Select accounts from the right pane of the Selector window. 

a. You can select multiple account codes by holding down the Ctrl key while selecting. 

3. Click Assign Accounts. 

The account(s) is/are listed under the group. 
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NOTE: Accounts assigned to a group cannot be reassigned to another group. 
Records/Page, this option loads the number of Accounts per page and by default only 
Accounts will be seen by a user. If user wishes to load more Accounts, please select 
values from the drop down list. 

 

To edit an account name or number 

1. Select the account name or number fields in the Master Account Code List. 

2. Click Edit Account. 

The Edit Account window appears. 

3. Make the necessary changes and click OK. 

 

Specifying Plan Rates  
NEC Communications Analyst allows you to set up the rate for each plan, which is used to 
calculate the cost associated with each phone call. The costing technique allows you to use 
prefix based (zonal) billing combined with variable time costing, if required. It allows you to 
generate reports using different rate plans and enables you to easily compare costs. 

 

To configure the rate plans for use in call costing reports 

1. From the SetUp menu, select Rate Plans. 

Rate Plans window appears as shown below:  

              

User should click Add button to create new rate plan and following window appears. 
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User should click Configure Zones button to create zones. The window has two sections - 
International and Domestic Area Codes. These sections have been described in detail below.  

 

International 
The section helps you to set other international country outside United States and also 
allows you to set the respective country code and the zone name. You can add a new 
country and the country code for countries not existing in the list. 
 
To add a new country code 
 
1. Click Add new country code. 
Add a new country code window appears. 
2. Specify the new country code along with the new country name  
3. Click OK.  

 

Domestic Area Code section 
The section helps you to set different area codes and area prefixes in the United States 
and the corresponding location information. You can add a new area code and the area 
prefix for area codes or area prefixes not existing in the list. 
 
To add a new area code 
 
1. Click Add new area code. 
Add a new area code window appears. 
2. Specify the new area code along with the state and major cities 
3. Click OK. 
 
To delete an area code 
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1. Select a particular area code that you want to delete. 
2. Click Delete area code. 
 
To add new prefix 
 
1. Click Add new Prefix. 
New Prefix window appears. 
2. Specify an area code from the drop-down list  
3. Type the prefix  
4. Click OK. 
 
To delete a prefix 
 
1. Select a particular prefix that you want to delete. 
2. Click Delete prefix.  
 

 

Plan Information and Rate Information Section   

This section helps you to plan the rate for different zones. Different rates are planned based 
on different time durations. In addition to a call cost, you can also add a specified surcharge or 
percentage modification for the cost onto each call or each report or both. For example, hotels 
add a per-call surcharge for all outgoing calls.  

To set a plan for each zone during a particular day and time 

1. Select a plan from the drop-down list. To create a new plan select <<New Plan>> from 
the list. 

2. Specify the tax and the surcharge adjustments. These adjustments are included in the 
billing report accordingly. If you do not wish to add taxes and surcharges, you will need 
to enter in a “0” value in these fields. 

3. From the Zone drop-down list, select a zone that you want to add to the selected Rate 
Plan and click Add. The zone is added to the Rate Information pane. To remove a 
zone, select the zone from the drop-down list and click Remove. 

a. To set both domestic and international zone, select the Zone tab on the left. 
You can select a zone and place the area code and the respective prefix 
(NPANXX) in the Zone. You can include multiple combinations of area codes 
and prefixes. After you have set new zones, click Save. 

b. To delete a zone, select the zone from the drop-down list and click Delete 
Zone.  

4.    If you select the Costing-Progressive option, then the cost of the call is calculated 
using the rates specified for initial time duration and also the rates specified for time 
duration thereafter (if the call extends from one time duration to another). 

For example, let us say the call durations are set as 12:00:00 AM to 12:59:59 AM, 
1:00:00 AM to 1:59:59 AM and so on. You start a call at 12:00:00 AM and the call ends 
at 1:30:00 AM, then the cost of the call is calculated based on the rates specified for 
12:00:00 AM to 12:59:59 AM as well as for 1:00:00 AM to 1:59:59 AM. 

If you do not select the Costing- Progressive option, then the cost of the call is 
calculated only using the rates specified for the initial time duration, even if the call 
exceeds to the next time duration. 

For the above example, the cost is calculated using the rates specified for 12:00:00 AM 
to 12:59:59 AM. 
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5. If you select the International Plan option, then all the international zones are 
displayed in the Zone drop-down. Otherwise, the domestic zones are displayed in the 
Zone drop-down. 

6. In the Rate Information pane, set the rate for a different day and time duration in a 
particular zone. 

To set new time duration, select the Time Slot tab on the left. You must enter the start 
and the end time in HH:MM:SS (24-hour format). To add a new row (when the 
available grid space is full), press the Tab key on the keyboard. 

After you have set new time duration for a particular zone, click save. 

You can set two different time slots and different rates for specific time duration. For 
instance, if you want to set the rate as one dollar ($1.00) for the first minute and ten 
cents ($0.10) for each additional minute in the time duration, then specify the settings 
as follows: 

• Duration of First Increment (Sec): 60 
• Cost of first increment: $1.00 
• Duration of Progressive Increment (Sec): 60 
• Cost of progressive increment: $0.10 

After all the required rate plans have been entered, click Save. 

Based on the rate plans, the cost for different phone calls is calculated. For details on how the 
cost is calculated, see Rate Plan Calculation.  

 

Rate Plan Calculation 
Variables used 

Total Surcharge: TS 
Total %: TP 
TAX %: TAXP 
Tax Surcharge: TAXS 
Duration of First Increment: DFI (In sec) 
Cost of First Increment: CFI 
Duration of Progressive Increment: DPI (In sec) 
Cost of Progressive Increment: CPI (In Sec) 
Rate per Call (%): RPC 
Rate per Call (Surcharge): RPCS 
Call Duration: CD (In Sec) 
Amount Charged for Call: AMT. 
First Increment Amount calculation 
First Increment Amount FI = 0 if CD/DFI < 1 
First Increment Amount FI = CFI if CD/DFI >= 1 
Progressive Increment Amount Calculation 
Progressive Increment Chargeable Time: TPI = CD - DFI 
Progressive Increment Amount PI = 0 if TPI is negative 
Progressive Increment Amount PI = ((TPI DIV DPI) + 1)*CPI 
Amount for the First and Progressive Increments 
AMT1 = (PI + FI) + RPCS +((PI + FI) * RPC/100) 
Final Amount 
AMT = (AMT1+TS) + ((AMT1+TS)*TP/100) + ((AMT1+TS)*TAXP/100) + TAXS 
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Call Costing 
 

Applying Rate Plans to Calls: NEC Communications Analyst allows you to apply the rate 
plan for each phone call. 

To configure the rate plans for use in call costing reports 

1. From the Tools menu, select Call costing. 

Call costing window appears as shown below:  

               
2. Click Criteria. 
      Criteria window appears. 

       
 

3. Click Select Rate Plan. 
      Select Rate Plan window appears. 
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4. Select the Domestic Plan / International Plan as shown below. 

 

5. Select Do Inbound Call Costing, If you want to apply the rate plan for Inbound calls. If 
we don’t select this option then Rate plan will be applied to only outbound calls. 

6. Click Cost CDR and it will apply the selected rate plan to the calls. 

7. Run Call costing reports and the report will show the call costing. 

8. User can specify fixed cost for extensions. Extension cost reports will show the fixed 
cost for each extension. We can specify same fixed cost for all the sites or different 
value for each site separately.  

Fixed cost for all the sites can be configured in the CDM.ini->General section as 
shown below. Users can change the label name as per their use and Extension Cost 
report will show the configured label name. 

�

              �

             OR 

      Fixed cost for each site can be configured in the MSConfiguration->Miscellaneous 
section as shown below. 
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PMS Integration 
Property Management Systems (PMS) in the hospitality industry were mainly developed to 
replace laborious task of maintaining transactions related to guest accounts. Guest System 
Services (GSS) like call accounting, Internet access, pay-per-view movies, electronic mini-bars, 
etc & ldots; are offered to guests. NEC Communications Analyst offers call accounting service 
to guests. The NEC Communications Analyst PMS integration helps to create a centralized and 
efficient management of lodging facilities. 

NEC Communications Analyst supports three protocols for communicating with PMS systems 
that are HOBIC A, HOBIC B and UHLL. HOBIC A and HOBIC B are similar to the HOBIC 
(Hotel Billing Center) United Standard format. NEC Communications Analyst also integrates 
with PMS applications using Lodging Link™ a product of Comtrol. Lodging Link™ has a 
universal interface that "speaks" in the proprietary Universal Hospitality Language Layer 
(UHLL), and provides connectivity and bi-directional communication between the vast array of 
PMSs and enterprise Server. 

Users who require integration with PMS systems using UHLL protocol should first install and 
configure Lodging Link™ from Comtrol Corporation. NEC Communications Analyst can 
communicate to the Lodging Link device through two (2) channels: Comm Port and TCP/IP 

 

Configuring Tool 
From the Start menu, select Programs>NEC>Communications Analyst>PMS Integration. 
The PMS Integration window opens. 
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• By default, HOBIC A will be selected as protocol for data transfer where Comm Port 
will be selected as the Communication medium, and Outbound Calls will be selected in 
the Call Costing section of the Advanced Options. 

• Configure communication and advance settings 

• Click the Save button to save the current settings 

• Click on the Start button to start the PMS service 

Clicking the Close button places the PMS Integration window in the system tray. Double 
clicking on the icon in the system tray opens the PMS Integration window. Right-click on the 
PMS icon in the system tray and select Close to close the PMS Integration window completely. 

 

Configuring the COMM Port 
1.From the Start menu, Programs>NEC>Communications Analyst> PMS Integration.  

The PMS Integration window opens.  

 

By default, Comm Port will be selected as the Communication medium, DTR & RTS will be 
checked and Outbound Calls will be selected in the Call Costing section of the Advanced 
Options. 

• In the "Port" drop-down list, select the communication port to which the serial cable is 
connected. NOTE that the MS Config port number of NEC Communications Analyst (if 
comm port is set) and the PMS Integration port number should be different. 
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• Select the Baud (e.g. 9600), Data Bits (e.g. 8), Parity (e.g. None), Stop Bits (e.g.1) 
from the Communication Settings section. NOTE that these settings should be similar 
to the settings in the PMS systems. 

• Select the Call Costing options as required. 

• Click the Save button to save the Comm port settings. 

Clicking the Close button places the PMS Integration window in the system tray. Double 
clicking on the icon in the system tray opens the PMS Integration window. Right-click on the 
PMS icon in the system tray and select Close to close the PMS Integration window completely. 

 

Configuring TCP/IP Port 
From the Start menu, Programs>NEC>Communications Analyst> PMS Integration. 

The PMS Integration window opens.  

 

• By default, Comm Port will be selected. 

• Click TCP/IP option button to configure the TCP/IP settings. 

• Enter the IP address of the Lodging link. E.g. 127.0.0.1 

• Enter the Port Number of the Lodging link. E.g. 1001 

• Select the Call Costing options as required. 
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• Click the Save button to save the TCP/IP settings. 

Clicking the Close button places the PMS Integration window in the system tray. Double 
clicking on the icon in the system tray opens the PMS Integration window. Right-click on the 
PMS icon in the system tray and select Close, to close the PMS Integration window 
completely. 

 

Starting and Stopping PMS Service 
Once the communication settings are configured, the system is ready to start the service. 

To Start the Service 

• Click the Start button in the PMS Integration screen and click the OK button in the 
subsequent window to start the PMS Service. 

• Once the service starts, the PMS Integration screen minimizes into the system tray. 

• The Start button in the PMS Integration window now changes to the Stop state, clicking 
on which stops the service. 

To Stop the Service 

• Right-click on the PMS Service icon or double-click on it in the system tray to display 
the PMS Integration screen. 

• Click Stop to stop the PMS Service. 

• Clicking Yes stops the service and the Stop button in the PMS Integration window 
changes to Start, clicking on which restarts the PMS Service. 

 

Generating PMS Report 
PMS reports will be generated for "Negative Acknowledgement", "No acknowledgement 
condition" and “Successfully sent to PMS" conditions. To generate a report for such 
conditions: 

• Click Report in the PMS Integration window. 

• If it is a report for "Negative Acknowledgement", the following report is generated. 

  

If it is a report for "No Acknowledgement", the following report is generated. 
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PMS report can also be generated from the NEC Communications Analyst application using 
Report options. When the extension number is configured using Configure Site, PMS report 
can be generated for specific extension or room.  

To view PMS Report from NEC Communications Analyst application:  

1. Select Start>Programs>NEC>Communications Analyst.  

2. On the toolbar, click Reports. The Reports window appears.  

3. Click on Advanced tab under Report category.  

4. Select PMS Report option.  

5. In Reports pane, select detailed listing of Call Records that did not reach PMS.  

6. Click Report after choosing desired criteria from the Criteria screen.  

 

 

Data Transfer Notification 
If the data transfer between NEC Communications Analyst and PMS fails, which may be due to 
connection issues, a message will pop out saying "NEC Communications Analyst to PMS data 
transfer failed". 
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Troubleshooting Connection Issues 
Serial Port Connection 

• Please check if the serial ports between the devices are connected properly 

• Ensure that the communication settings (Baud rate, stop bits, parity bits, data bits, DTR 
and RTS) for serial ports are configured correctly with respect to PMS systems 

 

TCP/IP Connection 

• Please make sure if the PMS systems for data transfer is running 

• Ensure the communication settings (IP address and port number) for TCP/IP are 
configured correctly with respect to PMS systems 

• Ensure that firewall settings will allow communication on the configured port. 

 

Applying Rate Plans to PMS costing: 
 
Now that you have created the rates, which you’d like to send to the PMS system for each call, 
you will now need to apply the costs. To do this: 
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1.  Open Automated Call Costing window  

2.  Setup Archival/Costing Automation 

 

 

 

3.  Select the checkbox for “Apply PMS Costing” 

4.  Open the Criteria Window  

5.  Click Button toward the bottom labeled “Select Rate Plan” 

6.  Select the corresponding rate plans from the drop down lists. 

7.  Select the checkbox to “Enable” the costing 

8.  Click on button labeled “Add” and name the costing profile. 
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Managing Reports 
NEC Communications Analyst allows you to generate reports for each call made or received. 
This helps you to analyze call information in useful and interesting ways. You can generate 
reports in graphical or textual format. By default, you can view the report on the screen. You 
can also print or export a report. 

NEC Communications Analyst allows you to automatically generate reports for a particular day 
or time using a set of predefined call information. NEC Communications Analyst allows you to 
e-mail, print or save the automatically generated reports to a file. You can also generate the 
report when you are away from your desk. 

 

To generate a report 

1.  On the toolbar, click Reports. 

       The Reports window appears. 

 

2. From the Report Category pane, select the type of report that you want to generate. 

NEC Communications Analyst has a set of reports for each report category. 

3. From the Reports pane, select the report that you want to generate. 

4. From the Report Options pane, select the types of calls that you want to include in the 
report. 

       Toll Free Calls: This includes calls to your local area code such as 800.  

       Toll Calls: This includes domestic calls outside your area code. 

6. Click the Criteria button, to specify the call records that you want to use for generating a 
report. For details, see Setting Report Criteria. 

7. Click the Run Report icon, to generate a text report. 
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8. Click the Graph icon, to generate a graphical report. 

 

Printing a Report 
You can also print the report content on a local or a network printer. 

To print a report 

1. Click the Print icon . 

The Print window appears. 

2. Enter the necessary information. 

3. Click OK. 

 

Exporting a Report 
You can export the report content to multiple file formats. Some of them are: 

� Microsoft Excel sheet (*.xls) 

� Acrobat (*.pdf) 

� Crystal Report (*.rpt) 

� Separated Values (*.csv) 

� HTML (Web Page) (*. html, *.htm) 

To export a report 

1. Click the Export Report icon . 

The Export window opens. 

2. From the Format drop-down, select the file format. 

3. From the Destination box, select the folder where you want to save the report. 

NOTE: When you export the report in .rpt format, you should use Crystal Report 9.0 to open 
and view the report. 

 

Searching for a Text 
You can search for a particular text in a report. 

To search the text 

1. Click the Search Text icon . 

The Search window appears. 

2. In the Find what box, enter the text that you want to search. 

3. Click Find Next. 
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Setting Report Criteria 
NEC Communications Analyst allows you to view your call information based on particular 
criteria. To view or drill down on specific call information, you can use the Call Selector 
window. You do not have to enter values for every field in this window. Every value in one of 
the field limits or excludes (depending on your choice) the call records that match the value. 

NEC Communications Analyst allows you to generate numerous reports using particular call 
selection criteria. You can save the values in the Call Selector window. You can also add, 
remove or rename criteria settings. 

 

To set a report criteria 

1. On the toolbar, click Reports. 

The Reports window appears. 

2. Click the Criteria button. 

The Call Selector window appears. 

 

3. In the Report Title box, type a title for the report. 

4. In the Date & Time Selection pane, select the time of the day (start and end time) for 
which you want to generate the report. 
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5. Select the Daily Slot option (calls that occurred between start time and end time every 
day for the selected dates) or Range option (calls that occurred between start date-
time and end date-time). 

6. Specify the length of call. You can either select from Call Duration (Minutes) list or 
you can specify Minimum and Maximum times in minutes. 

7. In the Group Selection pane, select the extension, account code or line that you want 
to include or exclude while generating the report. 

8. You can either type the extensions, account code or line or select them from existing 
list. 

To select the extensions, account code(s) 
• Click Select. The Selector window appears.  
• Double-click the extension, account code, to add them in the respective boxes 

in the Group Selection pane or double click on a department/group to add all the 
extensions and account codes related to it at a time.  

• To exclude the extension, account code; select the Exclude option against 
respective text boxes.  

To select line(s) 
• Click Line. The Line Selector window appears.  
• Select the line and double-click to add in the respective boxes in the Group 

Selection pane Or double click on a group (right pane) to add all the lines 
related to it at a time.  

• To exclude the line, select the Exclude option against respective text box.  
 
      In the Caller/Callee pane, type the caller or the callee name and phone number. To 

exclude caller or callee name and number from the report, select the Exclude option.  
 

9. You can use wild card characters such as asterisk (*). For example, *JON* would 
include or exclude both 'JONES MIKE' and 'SMITH JONATHAN'. Similarly, 800* would 
include both 8005551212 and 8004391313. You cannot use formatting characters such 
as parenthesis or hyphens. Multiple entries should be separated by comma. 

10. Select any of the Call Direction option. You can select Inbound, Outbound or Both 
options. 

11. All the site codes assigned to you are displayed in the Site Code box.  

 

To add a new site code 

1. Click Select Sites. 

The Select Site window appears. 
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All the sites assigned to you are displayed. 

• Select the particular site or select the Select All option, to select all the sites. 
• Click OK. 

12. In the Contact Selection pane, select the contact from the drop-down list. This is 
necessary for generating billing report for a particular contact. 

13. In the Client Matter pane, select the contact group from the drop-down list. This is 
necessary for generating billing report for a particular group of contact. 

14. In the Criteria Selection pane, you can add new criteria settings, delete them and also 
rename them. 

 

To add a new criteria setting 

• Specify the required criteria. 
• In the Criteria Selection pane, click Add. 
The Add new Criteria Set window appears. 
• Type the name of the criteria and click OK. 

 

To delete a criteria setting 

Select the criteria that you want to delete and click Delete. 

 

To rename a criteria setting 

• Select the criteria that you want to rename. 
• Click Rename. 
The Rename existing Criteria set name window appears. 
• Make the necessary changes and click OK. 

15. Click Accept. 

16. Click the Run Report button in the Reports window. The reports are generated based 
on the criteria that you set. 

You can also set some advanced criteria to view the report based on the DNIS, Exit Code, Exit 
State, Party Type and other attributes. 

To set an advanced criteria 

1. Click the Criteria button. 

2. The Advanced criteria window appears. Select any field that you want to include      
while generating the report 
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3. Click the DNIS/DID select button and double-click on DNIS/DID to add in the 

respective box. 

4. Click the Type of call select button and it will show the call type as Local/Long 
Distance/International/internal. Select any call type and double-click to add in the 
respective box. Report will show only the selected type of calls. To select multiple 
items use control key. 
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Generating Billing Reports 
You can bill your clients based on the time spent on the phone (if you are an attorney or a 
telemarketer). You can also generate a billing report for a particular Client Matter (group). For 
details on Client Matter, see section Using Client Matter. NEC Communications Analyst can 
easily generate reports, which shows you the time that you have spent talking to a client. 

The billing report consolidates your client's phone lines (for example, business numbers, home 
numbers, cell phone numbers) into one report. To create a successful billing report, you need 
to associate phone numbers to your client or contact. The information allows NEC 
Communications Analyst to create an association between those phone numbers and all the 
call data that you have collected from your phone or phone system. 

 

To create a billing report for a client or contact 

1. On the toolbar, click Contacts. 

The Contacts window appears.  

 

2. Assign a billing rate by selecting an account code in the contact information to that 
contact (in the Hourly Rate column). NEC Communications Analyst automatically 
calculates a total cost or charge for your phone calls. 

3. Select the particular contact for which you want to generate the billing report. 

4. Click the Billing button. 

The Create a Client Billing Report window appears 

 

5. Set the specific criteria as required. For details, see Setting Report Criteria. 

6. Click Run Report to generate the report. 
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Generating Graphical Reports 
To generate graphical reports 

1. In the Reports window, select the report for which graphical report can be generated. 

2. Click the Graph icon. 

The graphical window appears. 

 

 

The window provides a variety of configuration and manipulation features. The toolbar at the 
top of the graphical report offers various display options for your data.  

 

To view the axis properties for the graph  

1. Double-click on the graph and select Properties. 

The Chart FX Properties window appears.  
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2. Click the Axes tab. 

 

3. Select the axis from the drop-down list and click Details. 

The Axis Properties window associated with the axis selected appears.  

4. Make the necessary changes and click OK.  
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Using Call Distribution Map 
The report shows the call distribution using color codes on a map of the United States. Calls to 
multiple area codes within a state are combined to form a single total for the whole state. 
 

To view a call distribution map 

1. In the Reports window, select the Standard tab. 

2. Select the Geographic option. 

3. From the Reports pane, select United States calling distribution. 

4. Click the Graph icon. 

The Call Distribution (United States) window appears. 

 

5. Click Total Calls, to color the map based on the number of calls for a particular state 
with respect to the total calls.  

6. Click Total Duration, to color the map based on the duration of calls for a particular 
state with respect to the total duration of calls made.  

 

Automating Report Generation 
NEC Communications Analyst allows you to automatically generate reports on a regular basis. 
You can specify a particular time to generate a series of reports. You can also forward the 
generated report to one or more people as an email attachment. 

 

To setup automatic report generation 

1. From the SetUp menu item, select Report Automation. 

The Reports Automation Setup window appears. 
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2. Select the report that you want to automate. For details on how to select a report, see 
Managing Reports. You can specify the date and time to generate the report. You can 
generate a report once a month or daily. 

3. In the Report Scheduling Options pane, select the By Day option, By Date option or 
Every hour option. 

� By Day: Select this option to specify the Day of the Week (for example, Sunday) and 
the Week of the Month (for example, First week). For this example, all reports are 
generated on the first Sunday of every month. 

        

� By Date: Select this option to specify the exact date (for example, 15). For this 
example, the report is generated on 15th of every month. 

� Every Hour: Select this option to generate a report every hour. 

        

4. In the Save Automated Report Profiles pane, you can add a new automated profile 
setting, delete them and also rename them. You can also export automated profile 
settings to report criteria settings. 

5. Click the Enabled option to generate the report. 

 

To add a new automated profile setting 

• Specify the required profile. 
• In the Save Automated Report Profiles pane, click Add. 
The Add new Automation Set window appears. 
• Type the name of the automation profile and click OK. 

 

To delete a automation profile setting 

Select the automation profile that you want to delete and click Delete. 

 

To rename a automation profile setting 
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• Select the automation profile that you want to rename. 
• Click Rename. 
The Rename existing Automation set name window appears. 
• Make the necessary change and click OK. 

 

6. To export the automated profile settings to report criteria, click Export Profile to Reports. 
The automation profile is available under the Criteria Selection drop-down list in the Call 
Selector window. You can set the report criteria based on the automated profile. 

7. From the Destination drop-down list, select the location, where you want to send the 
generated report. You can select Printer, File, E-mail or FTP as the destination. 

� Printer: Select this option, to print the report. In the # copies box, specify the number 
of copies that you want to print. To specify the default printer, from the File menu, 
select Print Setup. 

 

� File: Select this option, to save the report to a file. In the File Name box, type or select 
the file name with the file extension. From the File Type drop-down list, select the file 
format. 

NOTE: If you select the Seagate Crystal Report File Type (RPT), you should have 
Crystal Report 9.0 to open and view the report. 

       

� E-mail: Select this option, to send the report as an e-mail attachment. Select the file 
name and the file type. Specify the list of e-mail addresses of people who should 
receive the report. Separate multiple addresses with a semicolon. You can even 
include a short message with the e-mail.  

NOTE: In the E-mail Settings pane, it is recommended to use ‘SMTP’ protocol instead 
of ‘MAPI’. NEC Communications Analyst will now support Gmail with SSL & SMTP for 
emails. Please refer to the section ‘Configuring Email settings for Gmail with SSL & 
SMTP’ from the document ‘NEC Communications Analyst Installation and 
Configuration Guide’. If the user has configured Configure Mail Settings from Start-
>programs->NEC->Communications Analyst->Tools->Configure Mail Settings, mail 
settings values will be pre-populated in the below fields. 
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   For SMTP protocol, specify a valid SMTP Server and port in the configuration. 
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� FTP: Select this option, if you want to send the report file to the specified FTP site. You 
should provide the name of the FTP server, a login name, a password and the 
directory to store the report file. Please ensure that you have all permissions for that 
directory. Default FTP port number is 21 and user can change this port number.  

      

8. Click Save, to generate automated reports. 

The scheduler runs automatically on the server side when you automate a process. 

When you save the report automation setup, NEC Communications Analyst schedules the 
report automation. To view the list of completed tasks, right-click the clock icon in the system 
tray. Select the Show Scheduler option. The list includes the profile name, type of profile and 
the time when it was completed… Refer To view the list of automated profiles section for 
further details. 

NOTE: If you make changes to an existing scheduled task in the Reports Automation 
Setup window, after the Scheduler is started, then you must click Save in order to take 
the changes into effect. This allows the scheduler to perform jobs as per your modified 
setting.  

To view errors (if any), do the following:  

Please go to the location C:\Program Files\NEC\Communications 
Analyst\Logs\Scheduler\Scheduler1.txt. 
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NEC Communications Analyst Automation Tool  
NEC Communications Analyst Automation Tool allows you to instantly execute any existing 
automation profiles set under NEC Communications Analyst Scheduler. This tool also helps the 
user re-execute failed/pending profiles caused due to network or database problems. You can 
also specify a particular time to re-execute any existing profile.  

Assume you have the following report automations Smtp_test & Ftp_test profile names have 
failed/pending under NEC Communications Analyst Scheduler caused due to network or 
database issues. 

 

You can resend these failed/pending automation profiles instantly using Automation Tool. In the 
NEC Communications Analyst Scheduler, Run Task tab is provided and Automation Tool 
window appears containing all the profiles that were configured under NEC Communications 
Analyst Scheduler window. 

 

Now you have to select failed/pending profile names from the grid and click Run button. You 
can also schedule these failed/pending profiles using Schedule option provided in the window. 



NEC Communications Analyst User Guide 

NEC Corporation of America 46

Managing Call Records 
NEC Communications Analyst collects and stores all call information in the NEC 
Communications Analyst database as a set of call records. You can perform the following tasks 
on the call records stored in the NEC Communications Analyst database: 

� Displaying Call Records 
� Sorting Call Records 
� Searching/Replacing within Call Records 
� Editing Call Records 
� Deleting Call Records 
� Importing Call Records 
� Archiving Call Records 
� Restoring Call Records 
� Automating Call Record Archival 
� Retrieving Call Information from Remote Locations 

 

Viewing Call Records 
NEC Communications Analyst allows you to view details of all the incoming and outgoing calls. 

To view call records 

1. From the View menu, select Inbound Calls (to view details of all the incoming calls) or 
Outbound Calls (to view details of all the outbound calls) or All Calls (to view both 
incoming and outgoing calls) or Internal Calls (to view details of all the station-to-
station calls). 
Or 
On the toolbar, click All Calls or Inbound or Outbound or Internal. 

 

The All Call Records or Inbound Call Records or Outbound Call Records or Internal Call 
Records window appears based on the selection  

 

2. To update the display that you are currently viewing, click the Refresh icon. 

3. To view the calls made during a particular period, click the Criteria icon. The Call 
Selector window appears. For details, see Setting Report Criteria. 
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To sort the call records 

� Click the column header.  

For example, to sort the call records by call duration, click the Duration header in the 
Call Records window. 

 

Searching and Replacing Call Records 
NEC Communications Analyst allows you to search and replace your currently stored call 
information. 

To search for a particular name or number 

1. From the View menu, select Inbound Calls (to view details of all the incoming calls) or 
Outbound Calls (to view details of all the outbound calls) or All Calls (to view both 
incoming and outgoing calls) or Internal Calls (to view details of all the station-to-
station calls). 
Or 
On the toolbar, click All Calls or Inbound or Outbound or Internal. 
The All Call Records or Inbound Call Records or Outbound Call Records or 
Internal Call Records window appears based on the selection. 

2. Select the Line Name or Phone number column. 

3. From the Edit menu, select Find. 

4. Enter the text that you want to search for and click OK. 

NOTE: The search finds any partial matches to the text that you entered. For 
example, if you search for John, then it returns records with "John" and "Johnson". 
The Find and Find Next menu item searches for the text in the active Call Records 
window. 

 

To replace a Line Name or Phone Number 
1. From the View menu, select Inbound Calls (to view details of all the incoming calls) or 

Outbound Calls (to view details of all the outbound calls) or All Calls (to view both 
incoming and outgoing calls) or Internal Calls (to view details of all the station-to-
station calls). 
Or 
On the toolbar, click All Calls or Inbound or Outbound or Internal. 
The All Call Records or Inbound Call Records or Outbound Call Records or 
Internal Call Records window appears based on the selection. 

2. Select the Line Name or Phone number column. 

3. From the Edit menu, select Replace. 

NEC Communications Analyst prompts for a name/number to search and a name or 
number to use as the replacement. 

4. Click Apply to execute the replace operation. 

NEC Communications Analyst reports any records, which match your replacement 
specification and makes the replacement in the information in the NEC 
Communications Analyst database. 
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Deleting Call Records 
You should periodically delete or archive call records that you do not need in your database. 
This helps you conserve disk space and optimizes reporting performance. 

To delete an individual call record 

1. From the View menu, select Inbound Calls (to view details of all the incoming calls) or 
Outbound Calls (to view details of all the outbound calls) or All Calls (to view both 
incoming and outgoing calls) or Internal Calls (to view details of all the station-to-
station calls). 
Or 
On the toolbar, click All Calls or Inbound or Outbound or Internal. 
The All Call Records or Inbound Call Records or Outbound Call Records or 
Internal Call Records window appears based on the selection.  

2. Select the call record that you want to delete. To select multiple call records, press the 
Ctrl key and select all the call records that you want to delete. 

3. Press the [DELETE] key on the keyboard. 

NOTE: Do not click the Delete button on the toolbar. 

To delete a set of call records 

1. From the Tools menu, select Delete Call Records. 
Or 
On the toolbar, click Delete. 

The Delete Call Records window appears. 

2. Click the Criteria button to select the exact criteria.  

3. To view the set of call records to be deleted, click the View button. 

4. Click the Delete icon. 
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Export CDR’s in the CSV format 
NEC Communications Analyst Users can now export CDR’s from the Communications Analyst 
application in the form of .CSV format. 

Before user export CDR’s, he/she needs to configure and set the order in which the columns 
appear in the Call Details should be exported. Click Start->Programs->NEC->Communications 
Analyst, Communications Analyst screen appears.��

�

Click Tools->Configuration for Call Details/Contacts, Configuration for Call Details/Contacts 
window appears. 

�

Select ‘Call Screen’ option from the combo box, total 61 different column names (from both 
calldata and call party tables of the Communications Analyst) with default ‘Export Order’ from 
1 to 61 appears as shown below. 

 

Column Name & UI Name is not an editable field. Export Order & Export Name is an editable 
field. For instance, if you would like to export CDR’s to a CSV file in which the CallStartTime, 
CallEndTime, CallDirection, CallDurationSec, CallingNumber information appear in the 
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order, then you should enter the following Export Order values as shown in this screen: 

Column Name Export 
Order 

CallStartTime 1 

CallEndTime 2 

CallDirection 3 

CallDurationSec 4 

CallingNumber 5 

 

Similarly, if you would like to export the Export Name as user defined, edit the existing value 
and click ‘Save’ button. 

Once you have completed and set the configuration on how to export call details, click either 
All/In/Outbound/Internal Call Records buttons provided in the Communications Analyst toolbar. 
All/In/Outbound/Internal Call Records screen appears with ‘Export’ button as shown below.�

�

 

 

 

User can export only All/In/Outbound/Internal Call Records, for example if you would like to 
export All CDR’s available in the Communications Analyst database, Click ‘Export’ button in 
the All Call Records screen, Export Calls window appears. 

 

Click ‘Browse’ button, Open window appears, enter file as ‘exportcalls04282010’ (don’t enter 
.csv file format). 
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�

Click ‘Open’ button, Export Calls window appears with the path where you wish to export a file. 

�

Now click ‘Export Calls’ button, once the export CDR’s process is completed, 
Communications Analyst window appears with ‘File Exported Successfully’ message. 

 

A sample CDR’s export .csv file is as shown below. 

 

�

�
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Importing Call Records 
NEC Communications Analyst allows you to import raw Data, structured Data, ACD raw CDR 
and ACD structured data from a Text file. If you are using a data logging device or similar 
memory device for storing call records, then you can use another program to capture the call 
information before analysis. You can also collect a set of call data from one or many locations 
for later analysis. 

1. Raw Data:  In the context of basic solution for recovery of data, as soon as Multi Site 
Reporting Call Data Manager (MSRCDM) gets the raw data from the switch, before it 
does anything else with the data or acknowledges receipt of data from the switch, raw 
CDR is written into a "msrcdm_rawCDR1_1.txt" log and raw ACD data is written into 
a ACD_rawCDR1_1.txt log file. 

2. Structured Data: Multi Site Data Manager (MSDM) receives data sent by multiple 
MSRCDMs (one per site, I.e., PBX). If there is a failure of receiving data or incomplete 
data is received, MSDM logs this structured CDR in a set of 
MSDM_StructuredData_1.txt log and structured ACD data is written into a 
MSDM_ACDStructuredData_1.txt log file. 

 

To import raw CDR 

1. Click Start->Programs->NEC->Communications Analyst->Tools->Import CDRs as 
shown below. 

 

Import CDRs window appears. 
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2. From the Select a site code drop-down list, select the site (site code) from where you 
wish to import the raw CDR. 

3. Click Refresh after selecting the site code. Phone System drop down will be 
automatically updated with the one that is configured in the Multi Site Configurator. 

4. In the Call Data Source pane, select the file type from which want to import. 

5. To import the call records from a Log File, browse and specify the file name containing 
the raw CDR information. The location for the raw CDR information is C:\Program 
Files\NEC\Communications 
Analyst\Logs\DataLogs\msrcdm_rawCDR1\msrcdm_rawCDR1_1.txt 

 

6. Click the Import CDR icon. On successful completion, the Finished Importing Call 
Records window appears. 
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7. Click OK. To view errors (if any), locate C:\Program Files\NEC\Communications 
Analyst\Logs\MSRCDM1\MSRCDM11.txt 

        

 

 

To import Structured CDR 

1. Click Start->Programs->NEC->Communications Analyst->Tools->Import CDRs as 
shown below. 

 

      Import CDRs window appears, select Structured Data tab as shown below. 
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2. To import the structured data, browse and specify the file name containing the 
structured data information. The location for the structured data information is 
C:\Program Files\NEC\Communications 
Analyst\Logs\DataLogs\MSDM_StructuredData\MSDM_StructuredData_1.txt 

 

3. Click the Import CDR icon. On successful completion, the Import Structured Data 
window appears. 

        

4. Click OK. To view errors (if any), locate C:\Program Files\NEC\Communications 
Analyst\Logs\MSDM\MSDM1.txt 
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5. Writing structure data logs made configurable. We can configure this in Multi Site 
Configuration->General->Logs->CDM.ini->MSDM section as shown below. The parsed 
CDR converted into structured data can also be stored in the file as backup before 
moving into DB. Setting the value to "YES" means the data will be written in the 
structured data file before flushing into DB. Setting "NO" will directly flush records into 
the DB without writing into file. Default value is "NO". 

�

 

6. Flushing Records from buffer to DB made configurable. We can configure this in 
CDM.ini->MSDM section as shown above. Default value set is 0 minute. "0" minute 
means record(s) will be flushed within less than one minute. If the value if greater than 
"0" then it will considered as minutes. Minimum is 0 and Maximum is 60 

 
 
 

To import ACD raw Data 

1. Click Start->Programs->NEC->Communications Analyst->Tools->Import CDRs as 
shown below. 

 

Import CDRs window appears. 
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2. From the Select a site code drop-down list, select the site (site code) from where you 
wish to import the raw CDR. 

3. Click Refresh after selecting the site code. Phone System drop down will be 
automatically updated with the one that is configured in the Multi-Site Configurator. 

4. In the Call Data Source pane, select the file type from which want to import. 

5. To import the ACD raw CDR from a Log File, browse and specify the file name 
containing the ACD raw CDR information. The location for the raw CDR information is 
C:\Program Files\NEC\Communications 
Analyst\BACKUP\Logs\ACD_rawCDR1\ACD_rawCDR1_1.txt 

 

6. Click the Import ACD icon. On successful completion, the Finished Importing Call 
Records window appears. 
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7. Click OK. To view errors (if any), locate C:\Program Files\NEC\Communications 
Analyst\Logs\ACDData1\ACDData11.txt. 

       

 

 

 

To import ACD Structured Data 

1. Click Start->Programs->NEC->Communications Analyst->Tools->Import CDRs as 
shown below. 

 

      Import CDRs window appears, select Structured Data tab as shown below. 
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2. To import the ACD structured data, browse and specify the file name containing the 
structured ACD data information. The location for the structured ACD data information 
is C:\Program Files\NEC\Communications  
Analyst\BACKUP\Logs\MSDM_ACDStructuredData\MSDM_ACDStructuredData_1.txt 

 

3. Click the Import ACD icon. On successful completion, the Import Structured Data 
window appears. 

        

4. Click OK. To view errors (if any), locate C:\Program Files\NEC\Communications 
Analyst\Logs\ACDData1\ACDData11.txt 
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Archiving Call Records 
NEC Communications Analyst allows you to remove call records from the call record database 
based on the criteria set by you and save it into an archive database for safe keeping. You can 
later restore these call records using the Restore Call Records option. You can also set up 
NEC Communications Analyst to automatically archive your call records on a regular basis 
using Archive database feature. 

Before you can archive call records to a file, you should configure your archive directory. For 
details, refer to the Installation Manual. 

 

To archive your call records 

1. Go to Start->Programs->NEC->Communications Analyst->Tools->Archive database, 
login page appears. 

 

NOTE: Unauthorized access to Archive/Restore is provided in order to maintain the 
security 

2. After providing correct login credentials, Archive database window appears.  

 

3. Click the Criteria icon, to select the specific criteria. 
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4. Click the Archive Data icon. 

The Select file to Archive/Restore window appears.  

NOTE: Make sure to select the option to “Remove data from Database” if you want to 
free room in the current reporting database. Otherwise, you are simply making a copy 
of the data specified in the criteria window. 

 

The configured directory appears in the Directory pane. The Files pane shows all the 
files stored in that directory. 

5. In the Specify Archive/Restore File box, type the name of the file where you want 
archive your call records. For example, Call Records.dat_bak. 

6. Click OK. The file keeps a copy of the call records depending on the criteria set by you. 

 

Restoring Call Records 
To restore previously archived call information 

1. Go to Start->Programs->NEC->Communications Analyst->Tools->Restore database, 
login page appears. 

 



NEC Communications Analyst User Guide 

NEC Corporation of America 62

NOTE: Unauthorized access to Archive/Restore is provided in order to maintain the 
security 

2. After providing correct login credentials, Restore database window appears.  

 

3. Select the duplicate check option is provided to quickly verify is there an already 
matching data present in the database. I.e. Duplicate/matching calls present in the 
database. Different options are provided and they are None, One, Random and All in 
the drop down list. Select any one of the value to proceed further. 

4. In the Restore File box, type the name of the file that you want to restore or click 
Browse to select the file. 

5. To view the set of call records to be restored, click the View icon. This prompts you for 
a file name and then displays the call information in a Call Record window.  

The Select Directory window appears.  

 

From the Files pane, select the file that you want to restore. 

The file name appears in the Specify Archive/Restore File box. 
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6. Click OK. 

7. Click Restore CDR. 

The archived files are restored.  

 

Automating Call Records Archival  
NEC Communications Analyst allows you to automate the Archive process, generating the 
archive file at pre-determined intervals.  

 

To setup automatic archival of your call records 

1. From the SetUp menu, select Archive/Call Costing Automation. 

The Archive/Call Costing Automation Setup window appears. 

        

2. In the Archive Options pane, select the Remove Data from Database option, to 
remove the call records from the call record database after the archival process is 
completed. 

3. In the Archive Options pane, select the Compress Data option, to compress (zip) the 
archived file prior to sending it via e-mail or FTP. The option helps you to reduce the 
archived file size to minimum, while sending it through e-mail or FTP. 

4. In the Archive Options pane, select the Apply Call Costing option, to calculate the 
cost of all call records, before archiving. 

5. In the Transfer Protocol pane, select the methods that you want to use to send the 
archive file. 

6. In the Archive Options pane, select the Do Archive option when performing an archival 
operation. This is not needed if only call costing is desired. 

� E-mail: Select this option, if you want to send the archived file to specified e-mail 
address as an attachment. You need to specify the profile to be used for the e-mail or 
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the Account name and password. 

NOTE: In the E-mail Settings pane, it is recommended to use ‘SMTP’ protocol instead 
of ‘MAPI’. NEC Communications Analyst will now support Gmail with SSL & SMTP for 
emails. Please refer to the section ‘Configuring Email settings for Gmail with SSL & 
SMTP’ from the document ‘NEC Communications Analyst Installation and 
Configuration Guide’. If the user has configured Configure Mail Settings from Start-
>programs->NEC->Communications Analyst->Tools->Configure Mail Settings, mail 
settings values will be pre-populated in the below fields. 

 

� FTP: Select this option, if you want to send the archived file to the specified FTP site. 
You should provide the name of the FTP server, a login name, a password and the 
directory to store the archived file. Please ensure that you have all permissions for that 
directory. Default FTP port number is 21 and user can change this port number. 

 

NOTE: NEC Communications Analyst only archives the file into the specified directory. 
You can specify the date and time to archive the call records. Selection of this option 
archives the file to the specified location in the Archive Directory field. 

7. In the Scheduling Options pane, select either the By Day option or the By Date 
option. 

� By Day: Select this option to specify the Day of the Week (for example, Sunday) and 
the Week of the Month (for example, First week). For this example, all call data are 
archived on the first Sunday of every month. 

 

� By Date: Select this option to specify the exact date (for example, 15). For this 
example, the call data is archived on 15th of every month. 
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8. Time of the day: Specify the time at which the data should be archived. 

9. Select the Archive Directory in which the archived file should be created. If you use 
the Browse button direct to the path configured for archiving, usually done during 
installation of NEC Communications Analyst Server installation. 

NOTE: Archive Directory can be changed from Windows Start->All Programs->NEC-
>Communications Analyst->Tools->Configure Archive Restore Directory. 

10. In the Save Automation pane, you can add a new automation setting, delete them and 
also rename them. 

 

To add a new automation setting 

� Specify the required automation setting. 
� In the Save Automation pane, click Add. 
The Add new Automation Set window appears. 
� Type the name of the automation and click OK. 

 

To rename a automation setting 

� Select the automation profile that you want to rename. 
� Click Rename. 
The Rename existing Automation set name window appears. 
� Make the necessary change and click OK. 

11. Click Save, to automate the archival process. 

12. If Archive automation profile does not have any calls for the criteria selected, an email 
“no matching records for the selected criteria” will be sent to the default mail id set in 
the NEC configure mail setting application. Scheduler will show the profile status as 
“Partial”. 

 

To delete a automation setting 

Select the automation setting that you want to delete and click Delete. The scheduler runs 
automatically on the server side when you automate a process. 

When you save the archival automation setup, NEC Communications Analyst schedules the 
archival automation. To view the list of completed tasks, right-click the clock icon in the system 
tray. Select the Show Scheduler option. The list includes the automation name, type of 
automation and the time when it was completed. Refer To view the list of automated profiles 
section for further details. 

NOTE: If you make changes to an existing scheduled task in the Archive/Call Costing 
Automation Setup window, after the Scheduler is started, then you must click Save in 
order to take the changes into effect. This allows the scheduler to perform jobs as per your 
modified setting. 

To view errors (if any), locate C:\Program Files\NEC\Communications 
Analyst\Logs\Automations\Automation1.txt 
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Managing Contacts 
In NEC Communications Analyst, a contact can be an individual, a group or a company 
associated with one or more phone numbers. You can associate one or more phone numbers 
to a contact to generate accurate reports. After few calls, you can build a group of phone 
numbers to a single contact. For example, you can associate (503) 442-7777 and (503) 442-
7778 to a single contact name.  

 

Adding a Contact 
To add a contact 

1. From the Edit menu, select Contacts. 
Or 
On the toolbar, click Contacts. 

The Contacts window appears. 

 

2. Click Add. 

The Contact Form appears. 
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Other than fields that are self-descriptive, some of the other fields that you need to enter are: 

� Full Name: Click the Full Name button, to enter the full name of the contact. Enter the 
name as required and click OK. 

� Account Code: Select a unique code for the account to whom the contact is 
associated with. 

� Contact Key: Each contact has a unique numeric or an alphanumeric key associated 
with it. This number is called the Contact Key. It helps you to identify each contact. 

� Billing Address: In this pane, select Work or Home. The bill for the calls would be 
mailed to you based on your selection. 

� Work: Data entered after selecting this tab provides information about contact's official 
details. All fields in this section are optional and field names are self-descriptive. Use 
the ellipses button against the Work Phone and Work Fax field to type the phone and 
fax number correctly (Country Code, City/Area Code and Local Number). 

� Home: Data entered in this section provides information about contact's home details. 
All fields in this section are optional and field names are self-descriptive. Use the 
ellipses button against the Phone and Fax field to type the phone and fax number 
correctly (Country Code, City/Area Code and Local Number). 

� Personal: Data entered in this section provides information about contact's personal 
details. All fields in this section are optional and field names are self-descriptive. 
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Modifying Contact Details 
To modify contact details 

1. On the Contacts window, select the contact and double-click. 

The Contact Form appears. For details, see  
Adding a Contact. 

After you make the necessary modifications, click Save and Close. 

To view contact details 

1. From the Edit menu, select Contacts 
Or 
On the toolbar, click Contacts. 

The Contacts window appears. 

All contacts along with their work addresses and other details are displayed in a tabular 
format.  

To assign one or more phone numbers to a contact 
1. From the Edit menu, select Contacts. 
Or 
On the toolbar, click Contacts. 

The Contacts window appears. 

 

2. Select the contact for which you want to assign the phone numbers. 

3. Click the Numbers icon. 

4.The Assign Phone Numbers window appears. The left pane lists the phone 
numbers (if any) associated with the contact. The right pane lists all the phone 
numbers from the call records that are not associated with the contact. 
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5. To assign a phone number to the contact, select the phone number from the right 
pane and click < 

6. To remove a phone number assigned to a contact, select the phone number from 
the left pane and click Remove. 

 

To add a phone number 

1. Click Add Phone. 

The Phone Details window appears. 

2. Type the Phone Number and Line Name. 

3. Click Save. 

To edit a phone number 

1. Select a phone number from the Unassigned Phone Numbers pane. 

2. Click Edit Phone. 

The Phone Details window appears. 

3. Make the necessary changes and click OK. 

To view the call history for a contact 

1. From the Edit menu, select Contacts. 

Or 

On the toolbar, click Contacts. 

The Contacts window appears. 
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2. Select the contact for which you want to view the call history 

3. Click Call History.  

All the calls made by or received by a particular contact along with all the details appear in a 
tabular format. 

 

Importing Contacts from Text files 
Data can be easily imported into NEC Communications Analyst from external data sources. 
Data from such databases and their inter-relationships are converted to NEC Communications 
Analyst Contacts, retaining their relationships in a way that can be put to NEC Communications 
Analyst use. NEC Communications Analyst supports the importing of text files exported from 
contact management software, such as Microsoft Outlook. 

To Import Text Files 

1. From the Edit menu, select Contacts. 
Or 
On the toolbar, click Contacts. 

The Contacts window appears. 

 

2. Select the Import icon. 
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The Import contacts from text file window appears. 

 

 

3. From the Source Type drop-down list, select the source of the text file such as MS 
Outlook 97/2000, Palm Pilot and ACT. 

4. From the Delimiter drop-down list, select the delimiter (character separating the fields 
in the text file) such as comma or tab. 

5. Click Browse. 

The Import File Name window appears. 

6. Select the file to import and click Open. 

On successful completion, the Finished Importing Contacts window appears. 

7. Click OK. 

 

To view errors (if any); please go to the following locations 

C:\Program Files\NEC\Communications Analyst\Logs\AuditTrailForContacts\import 
contacts.txt.  

and 

C:\Program Files\NEC\Communications 
Analyst\Logs\ImportFailed\ImportContactFailed10172012173027.txt 
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Import Contacts in the CSV/Text format 
NEC Communications Analyst Users can now import Contacts file with CSV/Text format to the 
NEC Communications Analyst application. 

Before user import Contacts, he/she needs to configure and set the order in which the columns 
appear in the Contacts should be updated. Click Start->Programs->NEC->Communications 
Analyst, NEC Communications Analyst screen appears.��

 

Click Tools->Configuration for Call Details/Contacts, Configuration for Call Details/Contacts 
window appears. 

 

Once you have completed and set the configuration on how to import contacts, click ‘Contacts’ 
button provided in the Communications Analyst toolbar, Contacts window appear. 

�

Click ‘Import’ button in the Contacts screen, Import Contacts window appears. 
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�

Select Delimiter value as ‘CSV File/Text File’, Click ‘Browse’ button, and Open window 
appears; select any exported contacts file with CSV/Text format. 

�

Click ‘Open’ button, CallAnalyst Enterprise Server window appears with ‘Import Contacts 
Complete’ message. 

 

To view errors (if any); please go to the following locations 

C:\Program Files\NEC\Communications Analyst\Logs\AuditTrailForContacts\import 
contacts.txt.  

and 

C:\Program Files\NEC\Communications 
Analyst\Logs\ImportFailed\ImportContactFailed10172012173027.txt 

 

Note: While importing contacts, we will consider First name, Last name and Company name 
for the duplicate check. If these fields are same for two contacts then we will consider them as 
duplicate and parse only the first contact and reject the second one.
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Export Contacts in the CSV format 
Communications Analyst Users can now export Contacts from the Communications Analyst 
application in the form of .CSV format. 

Before user export Contacts, he/she needs to configure and set the order in which the columns 
appear in the Contacts should be exported. Click Start->Programs->NEC->Communications 
Analyst, NEC Communications Analyst screen appears.��

 

Click Tools->Configuration for Call Details/Contacts, Configuration for Call Details/Contacts 
window appears. 

�

Select ‘Contacts’ option from the combo box, select ‘Import CSV File’ radio button, 
Configuration for Call Details/Contacts window appears.  

�

Column Name & UI Name is not an editable field. Import Order, Export Order & Export name 
are editable fields. By default the Import Order is not set whereas the Export Order is 
populated with default values. Also total 35 different column names (from contacts table of the 
Communications Analyst) are shown by default. 
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For instance, if you would like to export Contacts to a CSV file in which the FirstName, 
LastName, MiddleName, OrgName, Extn information appear in the order, then you should 
enter the following Export Order values as shown in this screen: 

Column 
Name 

Export 
Order 

FirstName 1 

LastName 2 

MiddleName 3 

OrgName 4 

Extn 5 

 

Similarly, if you would like to export the Export Name as user defined, edit the existing value 
and click ‘Save’ button. 

Once you have completed and set the configuration on how to export contacts, click ‘Contacts’ 
button provided in the Communications Analyst toolbar, Contacts window appear. 

�

Click ‘Export’ button in the Contacts screen, Export Contacts window appears. 

�

Click ‘Browse’ button, Open window appears, enter file as ‘exportcontacts04282010’ (don’t 
enter .csv file format). 
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Click ‘Open’ button, Export Calls window appears with the path where you wish to export a file. 

�

Now click ‘Export Contacts’ button, once the export Contacts process is completed, NEC 
Communications Analyst window appears with ‘File Exported Successfully’ message. 

 

A sample contacts export .csv file is as shown below. 

�
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User can also export Call Details associated with the specific contact. To achieve this, select a 
contact from the contacts data grid, click ‘Numbers’ button, assign few numbers from the 
‘Unassigned Phone Numbers’ list to a specific Contact Phone number as shown below and 
finally click ‘Close’ button. 

�

Once phone numbers are assigned to a contact, select the specific contact, click ‘Call History’ 
button, specific contacts call details will appear. 

 

In the specific contact Call Records, click ‘Export’ button and follow the export process to 
export call details belongs to specific contact. 
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Using Client Matter 
In NEC Communications Analyst, Client Matter is a feature that allows you to group contacts 
and generate billing reports for all the calls made to and from those contacts for a particular 
period. 

For example, consider two contacts Tom and Joe within NEC Communications Analyst, 
belonging to two different account services Civil and Criminal respectively in the same 
company. The company has some other contacts also. Now, assume that the account services 
Civil and Criminal have different hourly rates say $10 and $20 respectively. In law vertical, a 
senior person may be speaking to Joe and a junior person may be speaking to Tom. Based on 
the seniority, the cost may differ as $10 and $20 respectively. 

Now, you may need to generate reports only for contacts Tom and Joe and not for any other 
contacts in the company. This is where NEC Communications Analyst allows you to select a 
particular set of people using the Client Matter feature. 

 

Adding a Client Matter 
NEC Communications Analyst allows you to add a new client matter. 

To add a client matter 

1. From the Edit menu, select Client Matter. 

The Client Matter Definition window appears. 

 

2. Click Add. 

The Client Matter Definition window appears. 
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3. Enter the necessary details and click OK. 

 

Associating Contacts to a Client Matter 
NEC Communications Analyst allows you to associate contacts to a particular group or Client 
Matter. 

To associate a contact to a client matter 

1. From the Edit menu, select Client Matter. 

The Client Matter window appears. 

2. From the Client Matter drop-down list, select the client matter. 

3. In the Client Matter - Contacts Association pane enter the contact name that you 
want to associate. 

4. To search for a contact, click Search Contacts. You can provide wild card characters. 
You can search for any contact or the company or the address associated with the 
contact only. You cannot search for any account services to which the contact is 
associated. 

By default, all contacts are listed on the left hand side. 

5. To assign a contact to the Client Matter, select the contact from the left pane and click 
>>. 

6. To remove a contact from the Client Matter, select the contact from the right pane and 
click <<. 

NOTE: To modify a contact, double-click the contact in the left or right pane. 

 

Modifying a Client Matter 
NEC Communications Analyst allows you to modify a Client Matter. 

To modify a Client Matter 

1. From the Edit menu, select Client Matter. 

The Client Matter window appears. 

2. Click Edit. 

The Client Matter Definition window appears. 
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3. Make the necessary changes and click OK. 

 

Deleting a Client Matter 
NEC Communications Analyst allows you to delete a Client Matter. 

To delete a Client Matter 

1. From the Edit menu, select Client Matter. 

The Client Matter window appears. 

2. Click Delete. 

Deleting Client Matter window appears, confirming the delete action 

3. Click Yes to continue or click No to cancel. 

 

Customizing the Client Matter 
NEC Communications Analyst allows you to customize the Client Matter keyword. 

To customize the Client Matter keyword 

1. From the Edit menu, select Change Client Matter to. 

The Change Client Matter to window appears. 

 

2. Enter the new name for the Client Matter keyword, say Client Services. 

3. Click Save. 

You need to restart the NEC Communications Analyst application, to view the changes. 
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Traffic Analysis 
Traffic Analysis provides a user-friendly tool that helps to optimize the telecom resource 
utilization and maximize the ROI (Return on Investment) tied to such resources. If the Traffic 
Analysis icon is disabled, your software version does not include this module. Please contact 
your vendor for more information. 

Traffic Analysis analyses historical call data over periods, presents the analysis results in a bar 
chart and provides further details so that you can understand how best to deploy new 
resources, re-deploy existing resources or otherwise reconfigure the system to maximize the 
ROI - as per your definition. It graphically depicts usage of trunk groups for a specified time 
period and gives details of calls when trunk usage is at the maximum. 

Refer to the following sections to analyze the call data: 

• Setting criteria for Traffic Analysis 
• Details Section 
• What- If Analysis 
• Schedule Traffic Analysis 

Details have been described below. 

 

To display Traffic Analysis main window in NEC Communications Analyst 
1. Click the Start->Programs->NEC->Communications Analyst->Tools->Traffic Analysis 

as shown below. 
 

 
 

     Traffic Analysis window appears. 
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Setting Criteria for Traffic Analysis 
Traffic can be analyzed using various date intervals and time slots. Appropriate criteria have to 
be set in the following window. 

 

Start Date and Start Time 

Set the start date and the time from where the call data will be analyzed. The following issues 
needs to be considered while setting the start date: 

• Start date should not be less than a day compared to the date of the first call in 
the database 

• Start Date/Time should always be greater than the End Date/Time 
• Difference between the start date and end date should be <= 2 months 

 End Date and End Time 

Set the end date and time till where the call data will be analyzed. The following issues needs 
to be considered while setting the end date: 

• End date should be greater than a day compared to the last call in the database 
• Start Date/time should be always greater than the End Date/time 

Difference between start date and end date should be <= 2 months 

Site 

Select the site for which the data has to be analyzed. 

Circuit Group 
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Select the circuit group for which the call data has to be analyzed. 

Time Slot 

It is the interval of time for which the call data will be plotted in the call distribution chart. You 
can specify the time interval based on the level of detail to which the data needs to be 
analyzed. 

Time slot can be set in: 

• In minutes (multiple of 5 minutes) 
• In hours (1-23) 
• In days (1-n) 

By default this value is set to 1 hour. 

Inbound/Outbound 

Here you can select the direction of the calls that needs to be analyzed - Inbound, Outbound or 
both. 

 

Details Section 
This section provides specific details of the data being represented in the call distribution chart 

 

Total number of inbound calls: Displays the total number of inbound calls during the period 
of analysis. 

Total number of outbound calls: Displays the total number of outbound calls during the 
period of analysis. 

Maximum number of circuits utilized: Displays the maximum number of circuits utilized 
during the period of analysis. 

Duration for which maximum number of circuits used: Shows the total duration during 
which the maximum circuits are utilized. 

Detail: Shows the various times slots at which the circuit utilization is at the maximum 

 

WHAT-IF (Erlang-B Model) section 
Traffic Analysis computes the Call Success Rate for the given number of circuits in the selected 
period of time. Lesser value for Call Success Rate can indicate that some of the calls get 
missed. A higher value can indicate that existing circuits are underutilized. What-If analysis 
uses the Erlang B model to calculate the corresponding Circuits or the Call Success Rate when 
any one of them is changed. 

This section would be enabled on choosing a minimum of 5 days data for analysis with All Calls 
being checked. It will be enabled after the call distribution is plotted on clicking the Execute 
button. While doing What-If analysis only one parameter among Circuits or the Call Success 
Rate can be changed. 
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Check the option against the parameter to select the parameter to be changed. After setting a 
value for say circuits click on Apply. The corresponding value for Call Success Rate will be 
displayed. The call distribution graph will also vary to display the new pattern of calls. 

 

 

 

Schedule Traffic Analysis: 
Using the Schedule option users can schedule the task, which is similar to windows 
scheduler. 

With Scheduled Tasks, the user can schedule a Traffic Analysis report to run at a given time. 
Scheduled Tasks service starts each time you start Windows and runs in the background. 

With Scheduled Tasks, user can also: 

• Schedule a task to run daily, weekly, monthly, or at certain times (such as system 
startup).  

• Change the schedule for a task.  
• Stop a scheduled task.  
• Customize how a task will run at a scheduled time.  

When the task is executed, Traffic Analysis window will be invoked according to the criteria 
that are set provided the user is not logged off. However system can be locked. 

To schedule a task: 

1. Click Schedule of Traffic Analysis window. Following window will appear on screen. 

       

2. Click on Next below window will appear: 
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  Specify the task name and select any of the option from “Perform this task” lets say 
‘a1’ as the task name and ‘Daily’ as the selected option from “Perform this task”. 

 Click Next.

Select a Start Time, Perform this task and Start Date and click Next.
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6.  Select the appropriate options and click Next. Following screen will appear. 

7.  Enter the system password in the ‘Enter the password’ and ‘Confirm password’ fields.  

8. Click on Next. 
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 Click Finish to add the task name.

The task created can be found in Start-> Programs-> Accessories-> System tools-> 
Schedule tasks OR from Control panel-> Schedule tasks. 
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Campaign Assignment Tracker 
The Campaign Manager is a tool that allows users to associate extensions and DID/DNIS 
numbers with specific promotional campaigns. You can use this feature to track the call activity 
generated by specific campaigns to evaluate the performance and effectiveness. 

 

To access Campaign Assignment Tracker 

• From the Edit menu, select Campaigns – DID/DNIS Association.  

Agent – Campaign Association 
A realtor can use the Agent – Campaign association tool to associate the agents with one or 
more properties represented by Campaign numbers. Later the Campaign numbers can be 
configured with DID and DNIS numbers using the Campaign – DID/DNIS Association screen. 
One Agent can have multiple Campaign numbers but one Campaign number can be 
associated with only one Agent. You can also create custom groups and assign agents under 
the group.  

 

Manage Groups 
The Campaign groups can be created and any number of Agents can be assigned under a 
group. The image below lists such Campaign groups. 

 

Create a new group 

1. Click New Group.  

2. In the Group Name box, type the group name. 
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3. Click OK. 

Delete a Group 

1. Select the Group that has to be deleted. 

2. Delete it using the right-click option or using the Delete Group button. 

On deleting a group, all of its agents, Campaign numbers and the DID/DNIS assigned to it would 
get unassigned. 

Edit a Group 

1. Select a Group from the left pane of Agent – Campaign Association tab. 

2. Right-click the selected group. 

A popup menu appears. 

3. Select the Edit Group option. 

4. Make necessary changes to the Edit Group window and click OK. 

 

Manage Agents 
Agents can be assigned to various groups created.  The property deNOTEd by the Campaign 
number can be assigned to the agent.  

Access Agents 

In the Agent – Campaign Association, click the Agent tab. The Agent tab in the Agent –
Campaign Association window is as shown below.  
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The Master Agent list appears in the right pane. 

Create a new Agent 

1. Click New Agent. 

The New Agent window appears.  

2. In the Agent name box, type the Agent name. 

3. In the Agent number box, type the Agent number. 

4. In the Site box, type the site number. 

5. Click OK. 

The new Agent is added to the Master Agent list 

Delete an Agent 

Select the Agents you want to delete and press the [DELETE] key on the keyboard. 

Edit an Agent 

1. Select the Agent from the Master Agent list on the right pane.  

2. Click Edit Agent or right-click and choose Edit Agent from the popup menu option. 

3. Make necessary changes to the Edit Agent window and click OK. 

Assign an Agent to a Group 

1. Select a group from the left pane. An agent can be assigned only to Groups. 

2. Select the Agents from the Master Agent list on the right pane.  

3. Click Assign Agent or even the Agents can be selected and dragged from the right 
pane to a Group. 

The Agents assigned are listed under the Group. 

Unassign an Agent from a Group 

1. Select an agent from the left pane of Agent – Campaign Association tab. 

2. Drag the agent to the right pane or right-click and select Unassign from Group from 
the popup menu. 

This would result in the agent, Campaign numbers and DID/DNIS numbers linked to that 
particular Agent to be unassigned from the group. 

 

Manage Campaign numbers 
Campaign numbers indicate that the property can be assigned to an agent. These assigned 
Campaign numbers would get displayed in the left pane of Campaign – DID/DNIS Associations 
tab. 

Access Campaign numbers 

In the Agent – Campaign Association, Click the Campaign tab. The Campaign tab is shown in 
the figure 2. 

The Master Campaign list appears in the right pane.  
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Create a new Campaign number 

1. Click New Campaign. 

The New Campaign number window appears. 

2. In the Campaign number box, type the Campaign number. 

3. In the Description box, type the Campaign description. 

4. Click OK. 

The new Campaign number will be added to the Master Campaign list. 

Delete a Campaign number 

1. Select the unassigned Campaign numbers from the right pane. 

2. Right-click and select Delete Campaign from the popup menu. 

Edit a Campaign number 

1. Select the Campaign number from the Master Campaign list on the right pane.  

2. Click Edit Campaign or right-click the campaign and select Edit Campaign from the 
popup menu. 

3. Make necessary changes to the Edit Campaign Number window and click OK. 

Assign a Campaign number to an Agent 

1. Select an Agent from the left pane.  

A Campaign number can be assigned only to Agents. 

2. Select the Campaign numbers from the Master Campaign list on the right pane.  

3. Click Assign Campaign or drag the Campaign numbers from the right pane to the 
Agent. 

The Campaign numbers will be listed under the Agent. 

Unassign a Campaign number from an Agent 

1. Select a Campaign number from the left pane of Agent – Campaign Association tab. 

2. Drag the Campaign number to the right pane or right-click and select Unassign from 
the popup menu. 

This would result in the Campaign number being unassigned from the Agent and also the DID 
and DNIS number linked to it. 

 

 

Campaign – DID/DNIS Association 
The Campaign – DID/DNIS Association can be used to map the Campaign numbers with the 
DID and DNIS numbers. Only the Campaign numbers that are mapped with agents will get 
listed in the tree view control. One DID/DNIS number can be mapped with any number of 
Campaign numbers, but those Campaign numbers should have been assigned to only one 
Agent. 
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Manage DID/DNIS numbers 
You can assign a set of DID/DNIS numbers to Campaign numbers. These assigned DID/DNIS 
numbers would get displayed in the left pane of Campaign – DID/DNIS Associations tab. 

Access DID/DNIS numbers 

In the Campaign – DID/DNIS Association, click the DID tab to access the DID numbers and 
DNIS tab to access the DNIS numbers. 

The window below shows the DID tab in Campaign – DID/DNIS Association. 

 

The window below shows the DNIS tab in Campaign – DID/DNIS Association. 
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The Master DID/DNIS list appears in the right pane. 

Create a new DID/DNIS number 

1. Click New DID/DNIS numbers. 

The New DID/DNIS number window appears. 

2. Type the DID/DINS number in the DID/DNIS number box. 

3. Type the DID/DNIS description in the DID/DNIS description box. 

4. Click OK. 

The new DID and the DNIS number will be added to the respective Master DID or DNIS list. 

Delete a DID/DNIS number 

1. Select the DID/DNIS numbers from the right pane. 

2. Right-click and select Delete DIDDNIS from the popup menu. 

Edit a DID/DNIS number 

1. Select the DID/DNIS number from the Master DID/DNIS list on the right pane.  

2. Click Edit DID/DNIS or right-click and select Edit DIDDNIS from the popup menu. 

3. Make necessary changes to the Edit DID/DNIS number window and click OK. 

Assign a DID/DNIS number to a Campaign number 

1. Select a Campaign number from the left pane.  

2. Select the DID/DNIS numbers from the Master DID/DNIS list on the right pane.  

3. Click Assign DID/DNIS or drag the DID/DNIS numbers from the right pane to the 
Campaign number. 

The DID/DNIS numbers will be listed under the Campaign number. 

Unassign a DID/DNIS number from a Campaign number 

1. Select a DID/DNIS number from the left pane of Campaign – DID/DNIS Association 
tab. 

2. Drag the DID/DNIS number to the right pane or right-click and select the Unassign 
option from the popup menu. 

This would get DID and DNIS number to be unassigned from the Campaign number.  

 

DID/DNIS Reports 
The reporting of Campaign calls can be viewed as all the other reports. 

To Access Campaign – DID/DNIS reports 

1. From Reports window, in the Reports Category pane select the Advanced tab. 

2. Select Campaign – DID/DNIS option on the left pane. 

Report options would be listed on the right pane as shown in window below 

Two graphs are also included with the following options: 
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• Summary Call view by Campaign – DID by agent 

• Summary Call view by Campaign – DNIS by agent 

 

3. Click the Graph icon. 
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Managing Web Reports 
NEC Communications Analyst allows you to generate web reports for each call made or 
received. This helps you to analyze call information in useful and interesting ways. You can 
generate reports in graphical or textual format. By default, you can view the report on the 
screen. You can also export a report. 

NEC Communications Analyst allows you to automatically generate web reports for a particular 
day or time using a set of predefined call information.  

 

Launching web reports 
 We can launch web reports browser from NEC->tools menu as shown below 
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Connecting to a remote CA server 
Web reports allow you to view calls made or received on a remote CA server.  

1. Launch Create DSN for web reports window from NEC->tools menu 

 

 

2.Configure the remote CA server database details as shown below 

  

3.Launch Web report screen from Tool menu and the Login screen will show the Remote CA 
server details.  

4.Select the Remote CA server DSN and Give the Remote Server login credentials. 

5.Run the reports and report will show the remote CA server calls. 
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Web reports with IE 10 support 
Web reports support IE 10 only in compatibility mode.� We need to run web reports in 
compatibility mode as shown below. 

1. Launch web reports 
 

 
 
2. Go to IE settings and click F12 developers tools 

 

  
 

  
 
3. Go to Browser mode and select IE10 Compatibility view 
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4.  Login to the application  

 

 

5. Select criteria and run the report 
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Glossary 
ANI: Automatic Number Identification service is a service that provides the BN or billing 
number of a party that calls. This information can identify the caller and all pertinent information 
associated with them. 

Caller ID: Caller ID provides information about the caller, which is transmitted between the first 
and the second ring from the phone company. Standard Caller ID sends the caller's number 
only, while enhanced Caller ID sends both the caller's number and name. 

DNIS: Dialed Number Identification Service is a service that identifies an incoming phone 
number dialed by the caller. This is useful in a setup where there are several numbers to 
handle calls for specific products or services. 

DISA: Direct Inward Station Access is the feature where the caller can call into their voice mail 
and check messages or access their extension to make outbound calls elsewhere. 

Out of Area: If a phone call was made from an area where caller ID service is not supported 
but you have subscribed to the caller ID service, then the information NEC Communications 
Analyst receives and records as, is Out of Area. Sometimes Out of Area calls are transmitted 
with the phone number only. In those cases the name field will be blank. 

Private: If the caller has requested the phone company not to send caller ID information when 
they make calls, NEC Communications Analyst displays either Private or Blocked in the Line 
Name of the call record.  You can still assign these numbers to a contact. 

SMDR: Station Message Detail Records is a record that contains information related to a 
phone call such as extension called, number dialed, date and time of call and more. A SMDR is 
generated by a phone system and provided to the NEC Communications Analyst at the 
completion of an inbound or an outbound call. 

CDR: Call Detail Recording 

MDR: Message Detail Recording 


